win2008系统IIS火狐浏览器出现 SSL_ERROR_UNSUPPORTED_VERSION的解决方法

作者

火狐浏览器打开网站,出现了一个错误。主要原因是服务器端没有支持 TLS1.2 。知道了原因就好解决了,这里使用 IISCrypto 可以让IIS支持TLS1.2 ,操起起来也很简单。

错误的提示

建立安全连接失败

连接到 www.liuhaolin.com 时发生错误。对等端使用了不支持的安全协议版本。

错误代码:SSL_ERROR_UNSUPPORTED_VERSION

    由于不能验证所收到的数据是否可信,无法显示您想要查看的页面。
    建议向此网站的管理员反馈这个问题。

详细了解…

此网站可能不支持 TLS 1.2 协议,该协议现为 Firefox 的最低支持版本。启用 TLS 1.0 和 TLS 1.1 可能会成功连接。

未来的版本中将永久禁用 TLS 1.0 和 TLS 1.1。

解决方法

下载地址: https://www.nartac.com/Products/IISCrypto/

IISCrypto

勾选后,点击 apply 即可。