yum 更新错误 “Error: initscripts conflicts with centos-release-7-3.1611.el7.centos.x86_64″的解决办法

今天一台服务器,更新的时候。遇到的错误Error: initscripts conflicts with centos-release-7-3.1611.el7.centos.x86_64,按照提示的两种方法试了一下也没有解决。最后查看了,yum的配置文件,配置文件里禁止了更新了内核。然后删除了,禁止更新内核的部分。然后更新了一下,就这么愉快的更新成功了。

继续阅读

linux环境下,如何查看那些端口被占用了

linux环境下,查看端口的占用情况,有两个命令。分别是 lsof和 netstat。lsof (list open files)打印系统当前打开的文件,linux下,一切皆文件,网络也可以当做文件处理。netstat是在内核中访问网络连接状态及其相关信息的程序。这两个命令都可以很方便查看,那些端口被占用了。 这里简单介绍一下,这两个命令是如何使用的。如果losf 命令没有找到,需要先安装以下。

继续阅读

linux下安装中文版本的man手册

man手册(manual pages),是linux中重要的手册工具,默认是英文版本的,对于英文不好的同学,很有必要安装一份中文版本的。最好是查手册时候,中文英文都看下,这样方便阅读,记忆也深刻。这里总结以下,中文手册的安装方式,同时也简单介绍下man手册如何使用。

继续阅读